ワイズリマインダー

C841MでPPPoEサーバを構築してみた

RTX1220同士の拠点間VPNの評価の為に、
一家に一台あるシスコを使ってPPPoEサーバを構築してみた。

Cisco ルータを PPPoE サーバにするにはを参考にしました。

テスト構成は次の通り

既存のネットワークは無視しても良かったのだが、
気分的にWANに出てみたかったので接続した。

PPPoEサーバのGE0/0とGE0/1でPPPoEを受け付け
PPPoEクライアントにL2TPテスト用にGE0/3を使う事にした。

# 既存のN.W
ip name-server 192.168.28.254
!
interface GigabitEthernet0/5
 ip address 192.168.28.221 255.255.255.0
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
ip nat inside source list 1 interface GigabitEthernet0/5 overload
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/5


# 仮想WAN環境
ip dhcp excluded-address 20.20.21.201 20.20.21.254
!
ip dhcp pool virtual-wan
 network 20.20.21.0 255.255.255.0
 default-router 20.20.21.254
 dns-server 20.20.21.254
 lease 0 2
!
interface GigabitEthernet0/3
 switchport access vlan 200
 no ip address
!
interface Vlan200
 ip address 20.20.21.254 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
access-list 1 permit 20.20.21.0 0.0.0.255


# PPPoE
username user@example.local password 0 user
!
bba-group pppoe GROUP1
 virtual-template 1
bba-group pppoe GROUP2
 virtual-template 2
!
interface Loopback0
 ip address 20.20.20.254 255.255.255.255
!
interface GigabitEthernet0/0
 switchport access vlan 10
 no ip address
interface GigabitEthernet0/1
 switchport access vlan 20
 no ip address
!
interface Virtual-Template1
 mtu 1454
 ip unnumbered Loopback0
 peer default ip address pool POOL1
 ppp authentication chap
 ppp ipcp dns 20.20.20.254
interface Virtual-Template2
 mtu 1454
 ip unnumbered Loopback0
 peer default ip address pool POOL2
 ppp authentication chap
 ppp ipcp dns 20.20.20.254
!
interface Vlan10
 no ip address
 ip nat inside
 ip virtual-reassembly in
 pppoe enable group GROUP1
interface Vlan20
 no ip address
 ip nat inside
 ip virtual-reassembly in
 pppoe enable group GROUP2
!
ip local pool POOL1 20.20.20.211
ip local pool POOL2 20.20.20.212
!

これでPPPoEクライアントから接続するとPOOL1とPOOL2のIPが割り当てられる。
だがWANに出られなかった。
アクセスリストも書いているし、NATも有効なのになぜだ!?

はい・・・

既存のネットワークにルーティングテーブルを記述していませんでした。

既存のNWの841M

ip route 20.20.20.0 255.255.255.0 192.168.28.221

 

ちな、現在接続中の一覧を見るときのコマンド

show ppp all

コメントを残す

メールアドレスが公開されることはありません。

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください