ワイズリマインダー

C841MのPPPoEサーバに接続してきたクライアントにIPv6を割り当てて仮想NGN環境を作ってみた

PPPoEおよびNGN通信の為のテスト環境です。

Vlan10(G0/0)に接続してきたクライアントにIPv6を割り当てます。

ip dhcp excluded-address 192.168.10.201 192.168.10.254
ip dhcp pool pool-vlan10
 network 192.168.10.0 255.255.255.0
 default-router 192.168.10.254
 dns-server 192.168.10.254
 lease 0 0 1
 exit
!
ipv6 dhcp pool DHCP10v6
 address prefix 2001:FE80::10:0/112
 domain-name dhcp10v6.local
 exit
!
int Vlan10
 ip address 192.168.10.254 255.255.255.0
 ip nat inside
 ipv6 address 2001:FE80::10:1/112
 ipv6 nd prefix 2001:FE80::10:0/112 14400 14400 no-autoconfig
 ipv6 dhcp server DHCP10v6
 exit
!
int G0/0
 switchport access vlan 10
 no shut
 exit
!
!
!
username user@example.local password 0 user
!
interface Loopback10
 ip address 20.20.10.254 255.255.255.255
 exit
!
ip local pool PPPoE-POOL-10 20.20.10.1
!
interface Virtual-Template10
 mtu 1454
 ip unnumbered Loopback10
 peer default ip address pool PPPoE-POOL-10
 ppp authentication chap
 ppp ipcp dns 20.20.10.254
 exit
!
bba-group pppoe PPPoE-GROUP-10
 virtual-template 10
 exit
!
interface Vlan10
 pppoe enable group PPPoE-GROUP-10
 exit

コメントを残す

メールアドレスが公開されることはありません。

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください