ワイズリマインダー

特定のポートを解放しつつSoftBankのIPv6 IPoE+IPv4を利用してみた

今までHGW+ciscoの841Mを利用してSoftBank光を使用していた。
841Mで拠点間VPNやサーバー公開のために特定のポートを公開している。

今回SoftBankのIPv6高速ハイブリッドIPv6 IPoE+IPv4(以降IPoE)を契約した。
このIPoEはBBユニットを必ず使用しなければならなかった。
しかも、ルーティングテーブルはかけないしろもの。

さすが、クSoftBan(ry
と言う事で841Mで何とかしてみた。

VLANの第4オクテットの101-150は固定IPで使用、
151-200はDHCPで使用しているので、これらのみIPoE経由でWANに出たい。
残りのアドレスは今まで通りPPPoE経由でWANに出す。

接続はHGWからBBユニット(WAN)と841M(GE0/5)にそれぞれ接続する。
BBユニット(LAN)から841M(GE0/4)に接続する。
841Mに設定されているVLANは28。

 

まずは、IPoE経由で出たいアドレスをアクセスリストで許可する。

ip access-list extended A-IPoE
 10 deny ip any 192.168.0.0 0.0.255.255
 20 deny ip 192.168.28.96 0.0.0.3 any
 21 deny ip 192.168.28.100 0.0.0.0 any
 22 permit ip 192.168.28.96 0.0.0.31 any
 23 permit ip 192.168.28.128 0.0.0.63 any
 24 permit ip 192.168.28.192 0.0.0.7 any
 25 permit ip 192.168.28.200 0.0.0.0 any
 30 deny ip 192.168.28.0 0.0.0.255 any
 exit
ip access-list resequence A-IPoE 10 10

ルートマップを作成する

route-map R-IPoE permit 10
 match ip address A-IPoE
 set ip next-hop 192.168.27.254
 set interface GigabitEthernet0/4
 exit

BBユニット向けにNATを構築

interface GigabitEthernet0/4
 ip nat outside
 exit
!
interface Vlan28
 ip nat inside
 exit
!
ip nat inside source list A-IPoE interface GigabitEthernet0/4 overload

VLANにルートマップを適用する

interface Vlan28
 ip policy route-map R-IPoE
 exit

コメントを残す

メールアドレスが公開されることはありません。

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください